joomla25

  • This is a package for Joomla! 1.6/1.7 and 2.5 that allow you to inline a set of images from your favorite online gallery: SmugMug, Flickr, Picasa or any RSS feed in any article.

    This is a standalone version of the extension PhotoFeed that is also now part of CedSmugMug

    Features

    Photofeed 2.5.1 for J2.5 Released - Features

    Usage

    Photofeed 2.5.1 for J2.5 Released - Usage

    New ideas/features/bugs are always welcomed either through forums or  by using feedback

    What’s new?
    • Native Joomla 2.5 package
    • all the features

     

  • joomla_cms

    The extension has been converted successfully to Joomla! 1.6

    Photofeed can inline a set of images from your favorite online gallery: Smugmug, Flickr, Picasa or any RSS feed in any article.

    Now with Photofeed you can put in an article the following

    {rss uri=http://api.flickr.com/services/feeds/photos_public.gne?id=45007589@N00&lang=en-us&format=rss_200 limit=20}

    and here is the result

     

    Features

    • Update manager is also supported, keep up to date this extension with only one click using Joomla! 1.6 extensions manager
    • Photofeed 1.6 is Joomla! 1.6 native, it wont run in Joomla! 1.5 (use Photofeed 1.2.x)
    • Code produced is XHTML 1.0 Strict,
    • Tested in the following browser Firefox, Opera, Chrome, IE 8
    • License as always under GNU/GPL v3.0 or later

    Download

    Demo

    Documentation

    Visit the online WIKI

    Support

    Use the forum board

    Tracker for new features and bugs at http://jira.waltercedric.com/jira/browse/PHOTOFEED

  • joomlalovexsd

    I’ve created from scratch, all Joomla extensions XSD.

    Without them, Joomla accept any entry in manifest xml and never complains about

    • Mistyping, like a valid xml but that the Joomla installer do not understand or only partially,
    • Wrong constructs, xml tag child misplaced,
    • Invalid data type, like a path not being a valid path, an expected integer being a text and so on…

    Joomla just silently die during install or install only partially extensions. These days are over as developers with any decent IDE will be able to validate while typing and enjoy auto completion. To use them now just include them in all your manifest like this:

    <?xml version="1.0" encoding="UTF-8"?>
    <extension type="component" version="1.6" method="upgrade"
    xsi:noNamespaceSchemaLocation="http://raw.github.com/cedricwalter/joomla-xsd/master/component.xsd"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
    <?xml version="1.0" encoding="utf-8"?>
    <metafile version="1.6"  client="site"
    xsi:noNamespaceSchemaLocation="http://raw.github.com/cedricwalter/joomla-xsd/master/language.xsd"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <?xml version="1.0" encoding="UTF-8"?>
    <extension type="module" version="1.6" client="site" method="upgrade"
    xsi:noNamespaceSchemaLocation="http://raw.github.com/cedricwalter/joomla-xsd/master/module.xsd"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <?xml version="1.0" encoding="utf-8"?>
    <extension version="1.6" type="plugin" group="system" method="upgrade"
    xsi:noNamespaceSchemaLocation="http://raw.github.com/cedricwalter/joomla-xsd/master/plugin.xsd"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <?xml version="1.0" encoding="utf-8"?>
    <extension version="1.6" type="template" method="upgrade"
    xsi:noNamespaceSchemaLocation="http://raw.github.com/cedricwalter/joomla-xsd/master/templateDetails.xsd"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

    &160;

    A Bug request https://github.com/joomla/joomla-cms/issues/838 as been opened in Joomla CMS GIT at https://github.com/joomla/joomla-cms/ for being included somewhere where it will make more sense, somewhere like at http://www.joomla.org/xds/2.5/plugins.xsd

  • joomla_cms

    Protect any Joomla! 1.6 forms with CAPTCHA. SecurityImages has been written a long time ago,  born in 2004, first running under Mambo then rapidly Joomla! 1.0, 1.5 till today in Joomla! 1.6

    For all those that still don’t know what a CAPTCHA is:

    A CAPTCHA is a program that can tell whether its user is a human or a computer. You've probably seen them — colorful images with distorted text at the bottom of Web registration forms. CAPTCHAs are used by many websites to prevent abuse from "bots," or automated programs usually written to generate spam. No computer program can read distorted text as well as humans can, so bots cannot navigate sites protected by CAPTCHAs.

    Demo site

    See the demo here, login to administrator backend with login=visitor and password=visitor

    Features

    • Support all Joomla! 1.6 or 3rd party extensions that use the latest JForm fields
    • Update manager is also supported, keep up to date this extension with only one click using Joomla! 1.6 extensions manager
    • SecurityImages 6.x is Joomla! 1.6 native, it wont run in Joomla! 1.5 (use SecurityImages 5.x) nor Joomla! 1.0 (use SecurityImages 4.x)
    • License as always under GNU/GPL v3.0 or later
    • It support the latest CAPTCHA online engine: KeyCaptcha, NUCaptcha, Recaptcha

      

    KeyCaptcha

    Require to create a free account and register your site at https://www.keycaptcha.com/

    • Spam-bots are powerless against KeyCAPTCHA
    • It isn’t possible to transfer it to third parties for recognition
    • Only KeyCAPTCHA servers know the right solution
    • It works in all modern browsers
    • There are two modes of work: HTML5 and Flash
    • It supports iPhone, iPad and Android
    • It’s user-friendly

    securityimages.keycaptcha.joomla.1.6

     

    NUCaptcha

    Require to create a free account and register your site at http://www.nucaptcha.com/

     

    securityimages.nucaptcha.joomla.1.6

    ReCaptcha

    reCAPTCHA is a free CAPTCHA service that helps to digitize books, newspapers and old time radio shows.

    Require to create a free account and register your site at http://www.google.com/recaptcha/whyrecaptcha

    securityimages.recaptcha.joomla.1.6

    Limitations

    1. Only register Joomla! 1.6 form is protected by the captcha for now. This is because not all Joomla! 1.6 forms are using JForm Fields. I hope to see all forms rapidly migrated in later version (Joomla! 1.6.1???)
    2. Currently my own captcha engine: HNCaptcha, Calculator and Core are not migrated and thus not supported. They are anyway outdated.
  • Protect any Joomla! forms with CAPTCHA. SecurityImages has been written a long time ago,&160; born in 2004, first running under Mambo then rapidly Joomla! 1.0, 1.5 till today in Joomla! 1.6

    For all those that still don’t know what a CAPTCHA is:

    A CAPTCHA is a program that can tell whether its user is a human or a computer. You've probably seen them — colorful images with distorted text at the bottom of Web registration forms. CAPTCHAs are used by many websites to prevent abuse from "bots," or automated programs usually written to generate spam. No computer program can read distorted text as well as humans can, so bots cannot navigate sites protected by CAPTCHAs.

    What’s new

    • Joomla 2.5 ready!
    • Has been tested on Joomla!&160; 1.6/1.7 and 2.5
    • Update NuCaptcha API to the latest version,
    • Fix a regression where NuCaptcha was not working properly on register page,
    • This new version 6.0.2 is allowing you to use SecurityImages in all forms that use JForm, even in 3rd party components that are not specifically written to support any forms protections,
    • A new debug flag has also been added that write a file at /logs/plg_system_securityimages.php

    &160;

    SecurityImages6.0.1_for_Joomla_1.7_inRegister&160;SecurityImages6.0.1_for_Joomla_1.7

    Download / Documentation / Support

    To update your extension, Download the latest copy, uninstall from Extensions → Install / Uninstall → Pluginand install with the fresh copy.

  • SecurityImages has been updated to version 6.0.3 and correct 1 bugs for both Joomla 1.7 and Joomla 2.5.

    BUG: If enabled for Contacts, it prevents a backend administrator from saving contact details in the backend. It fails with a captcha error. This is because SecurityImages 6.0.2 and previous was enforcing a captcha entry, yet the backend cannot facilitate the display of the captcha.

    You can click the link below and install as normal via the Extensions Manager. or use the update manager (updates will display in the Extensions Managerunder Updates).

    Full list of changes available in GIT commit 18c1209801195e1138d61db87496408c38d2f49f

  • &160;